1С переменная не определена общиймодуль

Bell
20.02.2015 15:33
Прочитано: 3675

Имею общий модуль

Клиент (УФ и Обычное), Сервер и ВнешнееСоеденение = ИСТИНА

Возмжно как нибудь получить данные Запроса с другого общего модуля и какие там должны быть настройки.

Все время ошибка

<ОбщийМодуль.МА_РаботаСТабличнымиЧастямиКлиентСервер.Модуль(50,9)>: Переменная не определена (МА_УправлениеГабаритноВесовымиПоказателямиПереопределяемый) ААА = >МА_УправлениеГабаритноВесовымиПоказателямиПереопределяемый.ПолучитьГабаритноВасовыеДанныеНоменклатуры(СтрокаТаблицы); (Проверка: Тонкий клиент)

Yandex
Возможно, вас также заинтересует
E_Migachev
21.02.2015 16:58
Ответ № 1

процедура должна быть помечена как Экспорт и ни каких проблем? а ошибка же вообще в определении переменной. определи ее

Bell
23.02.2015 14:23
Ответ № 2

Функция ПолучитьГабаритноВасовыеДанныеНоменклатуры(Номенклатура) Экспорт

// Возвращаяю Все габаритно весовые параметры номенклатуры

Принимающая процедура тоже ЭКСПОРТНАЯПроцедура ПриИзмененииКоличествоЦена(Форма, ИмяТаблицы, ЗначениеПустогоКоличества = 0, ПрименяютсяСтавки4и2 = Ложь) Экспорт Элементы = Форма.Элементы; Объект = Форма.Объект; СтрокаТаблицы = Элементы[ИмяТаблицы].ТекущиеДанные; МА_РаботаСТабличнымиЧастямиКлиентСервер.РассчитатьСуммуТабЧасти(СтрокаТаблицы, ЗначениеПустогоКоличества);

E_Migachev
24.02.2015 01:46
Ответ № 3

галки у модуля проставил – что выполняется на сервере и клиенте?

Bell
24.02.2015 07:38
Ответ № 4

Сервер, Внешнее соединение, Клиент (обычное приложение)

2. МА_РаботаСТабличнымиЧастямиКлиентСервер (ПРИНИМАЮЩАЯ ПРОЦЕДУРА)

Клиент (УП), Сервер, Внешнее соединение, Клиент(Обычное приложение)

При формировании движения в 1С 8.2 на увеличение, при добавлении кода процедуры обработки, выдает ошибку: <РегистрНакопления.ОстаткиТоваровНаСкладе.МодульНабораЗаписей (3,21)>: Переменная не определена (ПоступлениеТоваров)
Скажите пожалуйста в чем ошибка.
Код прилагается:

Процедура ОбработкаЗаполнения(ДанныеЗаполнения, СтандартнаяОбработка)
// <<__КОНСТРУКТОР_ВВОД_НА_ОСНОВАНИИ
// Данный фрагмент построен конструктором.
// При повторном использовании конструктора, внесенные вручную изменения будут утеряны.
Если ТипЗнч(ДанныеЗаполнения) = Тип(«ДокументСсылка.ПоступлениеТоваров») Тогда
// Заполнение шапки
Комментарий = ДанныеЗаполнения.Комментарий;
Контрагент = ДанныеЗаполнения.Контрагент;
Ответственный = ДанныеЗаполнения.Ответственный;
Склад = ДанныеЗаполнения.Склад;
Для Каждого ТекСтрокаТовары Из ДанныеЗаполнения.Товары Цикл
НоваяСтрока = Товары.Добавить();
НоваяСтрока.Количество = ТекСтрокаТовары.Количество;
НоваяСтрока.Номенклатура = ТекСтрокаТовары.Номенклатура;
НоваяСтрока.Сумма = ТекСтрокаТовары.Сумма;
НоваяСтрока.Цена = ТекСтрокаТовары.Цена;
КонецЦикла;
КонецЕсли;
//>>__КОНСТРУКТОР_ВВОД_НА_ОСНОВАНИИ
КонецПроцедуры

Процедура ОбработкаПроведения(Отказ, РежимПроведения)
Движения.ОстаткиТоваровНаСкладе.Записывать = Истина;
Для каждого Стр Из Товары Цикл
Запись = Движения.ОстаткиТоваровНаСкладе.Добавить();
Запись.Период = Дата;
Запись.Номенклатура = Стр.Номенклатура;
Запись.Склад = Склад;
Запись.Количество = Стр.Количество;
Запись.ВидДвижения = ВидДвиженияНакопления.Приход;

Здравствуйте Изучаю 1с предприятние: 8.2 Практическое пособие разработчика .

1C ВЫДАЁТ ОШИБКУ :

<ОбщийМодуль. РаботаСДокументами. Модуль (12,25)>: Переменная не определена (Элементы)
СтрокаТабличнойЧасти = >Элементы. Материалы. ТекущиеДанные; (Проверка: Тонкий клиент)

Не могу понять в чём дело. Многое перепробывал в интернете не нахожу нормального объяснения.

Читайте также:  Усилитель форманта ум 0522 характеристика
Оцените статью
Добавить комментарий

Adblock detector