1С свернуть группу программно

О причинах неработоспособности сайта Вы можете уточнить у администрации – хостинг-провайдер .masterhost, отвечающий за его поддержку, предоставляет управление услугами и доменами их владельцам.

Здесь можно ознакомиться с актуальными акциями и выгодными предложениями от .masterhost

При разработке форм подборов и организации отборов для удобства работы может возникнуть задача по автоматическому раскрытию текущей группы.

  • упростить работу пользователю, выполнять 1 клик вместо 2;
  • явно дать понять ему, что есть вложенные группы.

В такой простой задаче может возникнуть стопор из-за особенностей динамического списка:

  • в метод Развернуть() таблицы формы следует передать идентификатор текущей строки (численное значение, согласно описанию в синтаксис-помощнике);
  • в динамическом списке, когда источник и основная таблица есть справочник, метод ТекущаяСтрока() возвращает ссылку этого справочника, к которому не применим метод ПолучитьИдентификатор().

Решение проблемы:

Первое что необходимо сделать: проверить или установить свойство «Отображение» у таблице в значение «Дерево»

Оказывается в метод Развернуть() в данном случае можно передавать эту ссылку, т.к. источник справочник, в котором нет дублей, следовательно система однозначно идентифицирует данную строку и сможет ее развернуть или свернуть. Аналогично работает и метод Развернут().

Код события при «АктивизацииСтроки»

тд = Элементы . Дерево . ТекущиеДанные ;
Если Не тд = Неопределено Тогда
Если Элементы . Дерево . Развернут ( Элементы . Дерево . ТекущаяСтрока ) = Ложь Тогда
Элементы . Дерево . Развернуть ( Элементы . Дерево . ТекущаяСтрока , Ложь ) ;
КонецЕсли ;
КонецЕсли ;

Для удобства пользователя добавим, авто раскрытие/сокрытие при выборе(двойном клике, по уже активной строке):

Код события «Выбор»

Процедура ДеревоВыбор ( Элемент , ВыбраннаяСтрока , Поле , СтандартнаяОбработка )

ТС = Элементы . Дерево . ТекущаяСтрока ;
Если Элементы . Дерево . Развернут ( ТС ) = Истина Тогда
Элементы . Дерево . Свернуть ( ТС ) ;
Иначе
Элементы . Дерево . Развернуть ( ТС , Ложь ) ;
КонецЕсли ;

Читайте также:  Чем заменить пасту гои в домашних условиях

Данная статья также применима к плану счетов, планам видов характеристик и расчетов (которые имеют иерархическую структуру).

Реклама — средство заставить людей нуждаться в том, о чем они раньше не слыхали.

Технологический блог фирмы 1С

Мы добавили в планировщик функциональность, позволяющую создавать визуально удобную, независимую вложенность измерений.

Сделать удобное мобильное приложение – дело непростое, это редко получается с первого раза. Для разработчика важно понять, насколько мобильное приложение удобно в использовании, где пользователь встречается с трудностями, использует ли пользователь мобильное приложение так, как задумал разработчик.

Чтобы решить эту задачу, мобильные приложения интегрируются с сервисами аналитики; сервисы помогают собрать информацию о статистике использования приложения, о действиях пользователей, источниках установок приложения и т.д.

Мы продолжаем развивать Систему взаимодействия в соответствии с нашим видением перспектив продукта и с учетом замечаний пользователей.

Для полноценной работы веб-клиента 1С иногда может потребоваться установить дополнительные программы: расширение для браузера и/или расширения для работы с файлами, криптографией, программой «1С:Предприятие – оповещения и запуск», внешние компоненты. Механизмы безопасности браузеров не дают сделать это полностью автоматически и требуют участия пользователя на некоторых фазах установки; в некоторых случаях может потребоваться перезапуск браузера.

В версии 8.3.17 мы переработаем интерфейс установки расширений, сделаем его более удобным для пользователей.

В версии 8.3.17 в функциональности демонстрации экрана в Системе взаимодействия (появилась в версии 8.3.16) произойдут изменения:

В версии 8.3.16 в Chrome демонстрация экрана

  • Была доступна, начиная с версии Chrome 56
  • Требовала установленного браузерного расширения
  • Позволяла демонстрировать:
  • Весь экран
  • Вкладку Chrome

В версии 8.3.17 в Chrome демонстрация экрана

  • Доступна, начиная с версии Chrome 72
  • Не требует установленного браузерного расширения
  • Позволяет демонстрировать:
  • Весь экран
  • Окна программ
  • Вкладку Chrome
Читайте также:  Функция обратной матрицы в excel

С целью помощи разработчикам при отладке и расследовании проблем мы ввели в платформу некоторые дополнительные возможности.

В версии 8.3.18 планируется следующее изменение: параметр командной строки /Out на ОС Windows будет выводить данные в файл в кодировке UTF-8 (поведение параметра будет унифицировано для всех поддерживаемых ОС).

Команда «Искать везде» используется для глобального поиска выделенного текста в поле ввода, в текстовом и форматированном документе, а также используется для поиска значения текущей ячейки в таблице или табличном документе.
Мы решили поменять сочетание клавиш для этой команды с Ctrl+Shift+C на Alt+L и скоро выпустим это изменение.
Это вызвано тем, что в типовых конфигурациях сочетание клавиш Ctrl+Shift+C используется для копирования в буфер обмена выделенных строк в таблице.

Нами принято решение, что изменение значений параметров:

  • Критический объем памяти процессов
  • Временно допустимый объем памяти процессов
  • Предел превышения (секунд) временно допустимого объема памяти процессов

можно будет делать с лицензиями уровня ПРОФ.
При этом поведение для опции "Временно допустимый объем памяти процессов" для ПРОФ и КОРП лицензий будет отличаться.
С лицензиями ПРОФ изменение параметра будет действовать только на перезапуск процессов, а с лицензиями КОРП – и на перезапуск процессов, и на прерывание объёмных клиентских вызовов сервера.

Сейчас в версии 8.3.15 эти опции доступны только с лицензиями уровня КОРП.

Изменение попадет в следующую финальную версию 8.3.15 (после 8.3.15.1656).

В версии 8.3.16 появится функциональность, позволяющая программно наполнять контекстное меню планировщика, передавая при этом информацию об области, на которой был произведен клик, будь то элемент, заголовок измерения, пустая область элементов и т.п. Это позволит разработчику конфигурации более гибко настраивать содержимое контекстного меню в зависимости от того, на чем был произведен клик. Появится также возможность задавать действие по умолчанию при нажатии левой кнопкой мыши в зависимости от области нажатия.

Оцените статью
Добавить комментарий

Adblock detector