1С загрузка из mxl

Встретилась задачка, нужно было загружать данные из mxl файлов выгруженных из другой базы 1С.

Файл MXL – это созданный в программе «1С: Предприятие» (последних версий 7.7 или 8) табличный документ.

вот код быстрой конвертации mxl в тз

Примеры по программированию в 1с 7.7, 8.1, 8.2

четверг, 6 февраля 2014 г.

Пример чтения файла mxl

Памятка по загрузки данных из файлов MXL(не путать с xml) , удобно при переносе данных из 7.7 в 8.2 и обратно.

Если ПустаяСтрока(Файл) Тогда
возврат;
КонецЕсли;

ТабДок = Новый ТабличныйДокумент;
ТабДок.Прочитать(Файл);

для Строка=1 по ТабДок.ВысотаТаблицы Цикл
для Колонка=1 по ТабДок.ШиринаТаблицы Цикл
Данные = ТабДок.Область(Строка,Колонка).Текст
КонецЦикла;
КонецЦикла;

Обработка осуществляет загрузку данных из табличных документов mxl, xlsx (ТОРГ-12, Счет-фактура, Универсальный передаточный документ) от поставщиков в табличную часть документа «Поступление товаров и услуг». Возможна доработка обработки для загрузки в любые другие документы и из любых других форматов файлов.

Обработка работает на 1С 8.1, 8.2, 8.3 на следующих конфигурациях: Управление торговлей 10.3, Бухгалтерия предприятия 2.0, Управление производственным предприятием.

Обработка будет бесплатно доработана под следующие конфигурации: : Управление торговлей 11, Бухгалтерия предприятия 3.0.

Обработка может быть доработана под любые другие конфигурации за отдельную оплату, стоимость работ 1000 р/час.

Код программы полностью открыт.

Так как обработка не носит регламентный характер, то ее обновление не требуется.

Техподдержка осуществляется бесплатно в течение 1 недели, далее техподдержка платная, стоимость 1000 р/час.

Ограничений на количество лицензий нет.

Установка программы осуществляется путем сравнения, объединения с файлом «cf» и добавление во внешний обработки заполнения новой обработки.

Дается гарантия возврата денег

Читайте также:  Четкие картинки на телефон для пацанов

Пошаговая инструкция по загрузке поступлений от поставщиков:

  1. Открыть документ «Поступление товаров и услуг» и в табличной части «товары» нажать на кнопку «Заполнить/загрузить из файла»
  2. Открывается обработка «Загрузка поступлений» – выбираем документ/файл товарной накладной в формате xml (формат CommerceML ), mxl или Excel
  3. По умолчанию заполнены наименование и номера колонок. Для корректного переноса данных из файла номера колонок необходимо отредактировать. Цифра в номере колонке должна соответствовать номеру колонки в файле. Также указываем номер первой строки (первой строкой считается строка с заполненными данными по товару)
  4. Сохраняем настройки для текущего контрагента
  5. Затем заходим в регистр сведений «Номенклатура контрагентов», в котором хранится соответствие наших номенклатур и номенклатур поставщика
  6. Сопоставляем номенклатуру поставщика с нашей номенклатурой. В случае если у нас нет такой номенклатуры, то создаем номенклатуру по строке (номенклатура поставщика автоматически добавляется в справочник номенклатур)
  7. Далее после клика на кнопку «Выполнить» – заполняется табличная часть «товары» в документе «Поступление товаров и услуг»

Инструкция по установке и настройке для разных контрагентов и разных форматов файлов прилагается.

Причины купить

  • -Возможность загрузки товаров и услуг от поставщиков из excel, xml, mxl
  • -Возможность сохранения настроек по загрузки товаров и услуг для текущего контрагента
  • -Возможность автоматического создания номенклатуры по строке
  • -Возможность простой доработки для загрузки из любых форматов файлов

Достоинства

  • -Быстрая и удобная загрузка товарных накладных от поставщиков из excel, xml, mxl
  • -Понятна любому пользователю настройка данной загрузки
  • -Автоматическое создание номенклатуры по строке, загруженной из файла
  • -Сохранение настроек по загрузки товаров и услуг для текущего контрагента
  • -Автоматическая адаптация обработки под разные конфигурации 1С (Управление торговлей, Бухгалтерия предприятия, Комплексная автоматизация, Управление производственным предприятием)
  • -Возможность доработки для загрузки из любых других файлов
Читайте также:  Трафаретный шрифт для coreldraw русский

Гарантия возврата денег

ООО "Инфостарт" гарантирует Вам 100% возврат оплаты, если программа не соответствует заявленному функционалу из описания. Деньги можно вернуть в полном объеме, если вы заявите об этом в течение 14-ти дней со дня поступления денег на наш счет.

Программа настолько проверена в работе, что мы с полной уверенностью можем дать такую гарантию. Мы хотим, чтобы все наши покупатели оставались довольны покупкой.

Для возврата оплаты просто свяжитесь с нами.

Оцените статью
Добавить комментарий

Adblock detector